Irssi core bugs

Notice: Undefined index: tasklist_type in /var/www/bugs.irssi.org/includes/class.tpl.php(128) : eval()'d code on line 85 Notice: Undefined index: tasklist_type in /var/www/bugs.irssi.org/includes/class.tpl.php(128) : eval()'d code on line 90
  • Status Closed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category core
  • Assigned To No-one
  • Operating System Linux
  • Severity Medium
  • Priority Normal
  • Reported Version Irssi 0.8.12
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 0
  • Private No
Attached to Project: Irssi core bugs
Opened by stania hwang (stania) - 2007-11-08
Last edited by Emanuele Giaquinta (ayin) - 2007-11-17

FS#544 - irssi doesn't align nicks properly for pubmsg

I want to right aligned nick, so I tried to apply tips in tips page, but it doesn't work properly.
I used
/format pubmsg {pubmsgnick $2 {pubnick $[-9]0}}$1
command, and I can find out it set properly with /format pubmsg right after that.
But after A message comes from others, aligning doesn't work properly
and /format pubmsg is changed like this
pubmsg = {pubmsgnick $2 {pubnick $0}}$1

is it bug? or your design?
if it is your design, I suggest you to rollback your design TT right-aligned-nick is very useful for me TT

Thank you for your regardness.

This task does not depend on any other tasks.

Closed by  Emanuele Giaquinta (ayin)
Saturday, 17 November 2007, 10:37 GMT
Reason for closing:  Not a bug
Wouter Coekaerts (coekie)
Thursday, 08 November 2007, 22:27 GMT
Aren't you running a script that's changing the format (nickcolor.pl for example)?
stania hwang (stania)
Friday, 09 November 2007, 00:16 GMT
Yes. I'm using nickcolor.pl! but it works properly on 0.8.10.
after I upgrade my binary with 0.8.12 source, it doesn't work TT.

I'll try it (not to use nickcolor.pl or other script)
stania hwang (stania)
Friday, 09 November 2007, 00:48 GMT
I tried it again without nickcolor.pl, and find out it's working properly.

I'll try to debug nickcolor.pl ㅡㅡa
stania hwang (stania)
Friday, 09 November 2007, 03:16 GMT
nickcolor.pl is overriding pubmsg without existing pubmsg format TT

Thank you Wouter!

Loading...