Irssi core bugs

Notice: Undefined index: tasklist_type in /var/www/bugs.irssi.org/includes/class.tpl.php(128) : eval()'d code on line 85 Notice: Undefined index: tasklist_type in /var/www/bugs.irssi.org/includes/class.tpl.php(128) : eval()'d code on line 90
  • Status Unconfirmed
  • Percent Complete
    0%
  • Task Type Bug Report
  • Category core
  • Assigned To No-one
  • Operating System Windows
  • Severity Medium
  • Priority Normal
  • Reported Version Irssi SVN
  • Due in Version Undecided
  • Due Date Undecided
  • Votes 0
  • Private No
Attached to Project: Irssi core bugs
Opened by Ailin Nemui (Nei) - 2005-09-03

FS#299 - Cygwin+Perl strange freeze

I want to use Irssi (IRC client) on Cygwin, but I'm failing horibly.

I am following the instructions in
<http://ai.onetrix.net/*/*Code/*Irssi/README.cygwin> and other people
claim to have created working Irssi versions with this instruction.

I also had me send a binary irssi.exe file from someone where it is
working, but the same file that works for her doesn't work for me.


I am having a quite strange problem. If I run irssi, I hear some noisy
disk activity, the cursor jumps to the top left position and then
that's it. Irssi freezes or whatever and nothing happens.

I do get a irssi.exe.stackdump file but I don't know whether that
contains usuable information.


I tried running Irssi in the native Win32 console terminal emulator,
rxvt and puttycyg. It shows the same sympthoms everywhere. However!, it
does seem to work in xterm, with the whole Xserver started. There it
doesn't crash. And if I start puttycyg from *within* xterm, it even
works in puttycyg.


I then tried running Irssi from gdb (I don't really know anything about
gdb), and surprisingly it starts when run from gdb.


The TERM environment variable doesn't seem to be responsible for this,
the behaviour doesn't change regardless of what I set it to. I also
tried making sure that the environment variables are the same in the
different terminal emulators/shells without success.


I compared the output of cygcheck -c with those of abovementioned
working install, but the cygwin setup itself seems to be nearly
identical.


Perl seems to be playing a role in this game, as an Irssi compiled with
--with-perl=no doesn't have this problem.


- it crashes in cmd/bash/zsh/anything that runs in the native terminal
emulator
- it also crashes in puttycyg
- it doesn't work in rxvt either
- but it seems to be working in xterm, with the whole xserver started
- it also works in puttycyg if I start puttycyg from within xterm(!)
- when started from within gdb, it doesn't crash (but isn't really
usuable because the output gets screwed up)
- TERM settings seem to be not related at all.


I posted the output of cygcheck on a website:
<http://ai.onetrix.net/cygcheck.out>

The irssi.exe.stackdump file is available as well, but I doubt it is
useful the way it is. <http://ai.onetrix.net/irssi.stackdump>


I hope anyone has a thought on this. Please tell me if you have good
ideas on google terms or to search the mailing list. I'll try to do
everything you ask of me that could help you resolve my problem
here ;-).

This task does not depend on any other tasks.

Ailin Nemui (Nei)
Sunday, 04 September 2005, 12:30 GMT
with the help of dbmathis from EFNet/#irssi I've managed to compile a working irssi version by specifying a --prefix that doesn't blend in with Cygwin. Any thoughts :/?

Loading...